[pgbr-geral] Versão do Postgresql

Pablo Sánchez phackwer em gmail.com
Sexta Fevereiro 26 02:17:56 UTC 2010


Em 25 de fevereiro de 2010 22:21, Nilson Chagas
<nilson.chagas.silva em gmail.com> escreveu:

> Então eu passei a bola para o suporte veja a resposta que tive:
>
> "Pelo que verificamos a versão mais recente disponível pelos desenvolvedores
> da distribuição CentOS é a 8.1.18, por isso essa foi a versão instalada pelo
> script de instalação do Cpanel. É sempre feita a instalação da versão mais
> recente disponibilizada pela distribuição Linux usada.
>
> Recomendamos que você utilize a versão já instalada até que a nova versão
> seja distribuida pela CentOS."
>
> A não ser que esteja muito enganado, mas acredito que isto não procede. Se a
> distribuição não oferece em seus pacotes, tem que ser feito "na unha", ou
> estou errado??

Sim, mas nesse caso o suporte não o fará para você. Eles se limitam a
dar suporte àquilo que eles podem automatizar, afinal de contas, você
não é o unico cliente deles. Se por algum motivo, sua versão
"compilada na unha" parar de funcionar, eles definitivamente não vão
ter a menor idéia de como corrigir, e provavelmente não vão nem
conseguir verificar o configure --version para saber como tinha sido
compilado antes e repetir a operação.

Ou seja, nesse caso, se você o fizer, terá que fazer na mão, sozinho e
assumir o risco de estragar tudo. Se não tem nada ainda rodando no
servidor, pode até valer a pena se arriscar 1 ou 2 vezes. Se baixar o
PostgreSQL e compilar do fonte sem alterar o prefiz, ele colocar tudo
automaticamente no /usr/local/pgsql, ou seja, fica fácil para remover,
é só apagar essa pasta e começar de novo do zero. E se nada mais der
certo, você pode pedir a eles que reinstalem o servidor tal qual
estava quado foi contratado, porque com certeza eles tem alguma imagem
pronta para colocar em um jail.

Quando o PG estava na versão 7, escrevi este artigo. Está
desatualizado, mas praticamente tudo que está aí ainda é válido. O que
não for válido, é fácil de ver no manual como mudou.
http://www.idsl.org.br/index.php?cont_cod=48

Um abc

Obs; se você o fizer, não venha me responsabilizar caso estrague tudo.
Como disse, a documentação está desatualizada, e eu tenho utilizado o
ports do FreeBSD para instalar o PG.

-- 
=================================
Pablo Santiago Sánchez
Análise e Desenvolvimento de Sistemas Web
Zend Certified Engineer #ZEND006757
phackwer em gmail.com
(61) 9975-0883
http://www.sansis.com.br
http://www.corephp.com.br
"Quidquid latine dictum sit, altum viditur"
=================================



More information about the pgbr-geral mailing list