[pgbr-geral] Problemas com versões pg_dump

Jackson Weber jacksonsw em brturbo.com.br
Sexta Março 6 08:53:58 UTC 2009


eu tive um problema desses e resolvi copiando o pg_dump da versão nova pro diretório do pgAdmin, pois eu estava tentando realizar um backup através do pgAdmin. Onde você está executando o comando Shell, é o Servidor que possui a instalação do 8.3.6 ou não. Se não faz isso entra no Servidor com a versão 8.3.6 e copia o pg_dump para o diretório onde você está chamando o pg_dump do script.
  ----- Original Message ----- 
  From: Diego Ramos 
  To: pgbr-geral em listas.postgresql.org.br 
  Sent: Thursday, March 05, 2009 12:31 PM
  Subject: [pgbr-geral] Problemas com versões pg_dump


  Boa Tarde a todos,

  Estou tendo problemas com uma linha em um script shell,a linha segue abaixo :

  su postgres -c "pg_dump -a -f /sige/Backup/$Arquivo -Fc sige"

  o erro é o seguinte : 
  pg_dump: server version: 8.3.6; pg_dump version: 8.3.5
  pg_dump: aborting because of version mismatch  (Use the -i option to proceed anyway.)



  Até o momendo coloquei a opção -i ( su postgres -c "pg_dump -i -a -f /sige/Backup/$Arquivo -Fc sige" ) e está funcionando perfeitamente,mas emite um aviso,gostaria de saber como resolver a questão da versão.

  Grato.
  -- 






------------------------------------------------------------------------------


  _______________________________________________
  pgbr-geral mailing list
  pgbr-geral em listas.postgresql.org.br
  https://listas.postgresql.org.br/cgi-bin/mailman/listinfo/pgbr-geral
-------------- Próxima Parte ----------
Um anexo em HTML foi limpo...
URL: <http://listas.postgresql.org.br/pipermail/pgbr-geral/attachments/20090306/19051088/attachment.html>


More information about the pgbr-geral mailing list